anterior
Tweet about this on TwitterPin on PinterestShare on LinkedInShare on Google+Email this to someoneShare on Facebook
QR CODE

Excel: SOMARPRODUTO CONDICIONAL

Olá pessoal!
Tudo bem com vocês? Nesse tutorial vou mostrar um recurso avançado da função SOMARPRODUTO. Para isso vou começar a explicar um exemplo simples e iremos chegar a um exemplo avançado.

  1. Abra o Excel e clique em Pasta de trabalho em branco:1
  2. Em seguida, digite a seguinte planilha abaixo:2
  3. Para calcular o valor (R$) que a empresa tem em Total em estoque podemos fazer da seguinte forma:

a) Multiplicar a Quantidade pelo Preço, mas será preciso criar uma nova coluna:  chamada Valor Total.

Multiplicando a Quantidade pelo Preço, assim como mostra a imagem abaixo.

3

b) Agora no campo Total em estoque (em R$), basta somar o intervalo de células da coluna Valor Total.

4

c) Abaixo temos a imagem da planilha já resolvida.

5

A forma correta para executar o mesmo cálculo seria utilizar a função SOMARPRODUTO.

A função SOMARPRODUTO multiplica as variáveis e depois as soma.

Estrutura =SOMARPRODUTO(matriz1;matriaz2…)

Em nosso exemplo estamos multiplicando a célula C2 * D2, C3 * D3, C4*D4 até C9*D9 e depois é feito a soma de cada multiplicação.

6

O resultado será:

7

SOMARPRODUTO CONDICIONAL

Agora vamos aprender um recurso avançado da função SOMARPRODUTO, que possibilita aplicarmos uma condição a função.

Exemplo: Podemos efetuar o mesmo cálculo no exercício visto porém para os produtos da Unidade 1 ou Unidade 2.

Utilizando a mesma planilha, adicione dois campos para utilizarmos a SOMARPRODUTO condicional.

8

A estrutura da função fica da seguinte forma:

=SOMARPRODUTO(matriz1;matriz2;–(intervalo-da-condição=”Unidade 1″))

Intervalo-da-condição: Selecionaremos o intervalo de células onde encontramos o intervalo.

Condição: Escolhemos a condição quer será aplicada a função → =”Unidade 1”.

9

A estrutura fica da seguinte forma para o campo Total Unidade 1:

=SOMARPRODUTO(C2:C9;D2:D9;–(A2:A9=”Unidade 1″))

A estrutura fica da seguinte forma para o campo Total Unidade 2:

=SOMARPRODUTO(C2:C9;D2:D9;–(A2:A9=”Unidade 2″))

A planilha resolvida fica da seguinte forma:

10

E terminamos por aqui galera!

Espero que tenham gostado desse tutorial. Qualquer dúvida é só deixar um comentário. Qualquer sugestão será bem vindas =]


 

Sobre o autor:

11

André Victor – Instrutor na Unidade de Santos. Cursando Análise e Desenvolvimento de Sistemas na universidade Centro Universitário Monte Serrat.

Curtam e compartilhem esse post e sugiram outras vídeos aulas para nossos instrutor postar!

 

Próximo

Postado por

Postagem Relacionada

lulua
Criando menu Dropdown Condicionais no Excel
O que é um menu Dropdown? Um menu dropdown é muito útil quando se tem
  • Gustavo Rodrigues

    muito obrigado

  • Kemily Beatriz

    Mito útil! Obrigada.